Actions
Bug #2006
openCompany Registration – Duplicate Phone Number Validation Occurs Only at Final Step issue:
Start date:
01/14/2026
Due date:
% Done:
0%
Estimated time:
Device/Browser/API:
Web Portal
Environment:
Production
Current Behaviour:
- After completing all steps of the Company Registration and clicking Complete Registration, an error message is displayed. “Company with this phone number already exists.” The validation is triggered only at the final step instead of earlier.
Expected Behaviour:
- Instead, the Phone Number field in Step 2 (Contact Information) should immediately validate and display an error message such as: “This phone number is already registered.
Root Cause:
Funcational Gap
Root Cause Detail:
* After completing all steps of the Company Registration and clicking Complete Registration, an error message is displayed. “Company with this phone number already exists.” The validation is triggered only at the final step instead of earlier.
* Instead, the Phone Number field in Step 2 (Contact Information) should immediately validate and display an error message such as: “This phone number is already registered.”
Description
- After completing all steps of the Company Registration and clicking Complete Registration, an error message is displayed. “Company with this phone number already exists.” The validation is triggered only at the final step instead of earlier.
- Instead, the Phone Number field in Step 2 (Contact Information) should immediately validate and display an error message such as: “This phone number is already registered.”
Files
No data to display
Actions