Actions
Bug #2357
open(Web portal / Mobile Browser) Get In Touch Page – Form Fields Not Reset After Successful Submission issue:
Start date:
03/03/2026
Due date:
% Done:
0%
Estimated time:
Device/Browser/API:
Web Portal
Environment:
Production
Current Behaviour:
- After filling all required fields and clicking the “Send Message” button, the success message “Thank you for your message! We'll get back to you soon.” is displayed. When clicking “OK,” the previously entered data remains in the form fields and is not cleared.
Expected Behaviour:
- After successful form submission and clicking “OK,” all form fields should be cleared/reset automatically.
Root Cause:
Funcational Gap
Root Cause Detail:
* After filling all required fields and clicking the “Send Message” button, the success message “Thank you for your message! We'll get back to you soon.” is displayed. When clicking “OK,” the previously entered data remains in the form fields and is not cleared.
* After successful form submission and clicking “OK,” all form fields should be cleared/reset automatically.
Description
- After filling all required fields and clicking the “Send Message” button, the success message “Thank you for your message! We'll get back to you soon.” is displayed. When clicking “OK,” the previously entered data remains in the form fields and is not cleared.
- After successful form submission and clicking “OK,” all form fields should be cleared/reset automatically.
Actions